Thursday, September 20, 2007

Quake для телефонов Nokia S60 3rd edition FP1

Quake для телефонов Nokia S60 3rd edition FP1 Порт знаменитой игры шутера от первого лица, для телефонов Nokia S60 3rd edition FP1, - единственная вещь, которая не работает - это сетевая игра.
Для игры необходим телефон S60 3rd Edition Feature Pack 1 (N95 или E90) и процессор ARMv6.
К сожелению, игра не будет работать на предыдущих моделях S60 3rd Edition (non-FP1) . Для работы Вам нужно будет установить библиотеки PIPS C Runtime libraries.
Установка
1. Найдите дистрибутив игры, необходимы файлы *.pak (подойдут файлы как от демо версии, так и полной компьютерной версии игры)
2. Создайте папку "quake1" в корне карты памяти
3a. Если у вас есть полная версия просто скопируйте папку "ID1" в папку "quake1" .
3b. Если у Вас демо версия,
создайте папку "ID1" в папке "quake1" и скопируйте *.pak файлы в нее
4. Если Вы хотите слышать фоновую музыку, создайте папку "cdaudio" в папке "quake1". Потом перекодируйте audio cd в mp3 формат, файлы необходимо называть от 1.mp3 до 10.mp3. Затем просто переносим
mp3 файлы в папку "cdaudio". Если у вас нет аудио файлов, в игре просто будет отсутствовать фоновая музыка.
5. Установите библиотеку Symbian P.I.P.S. c, все теперь монжна устанавливать сам порт quake.

Скачать
quake_v101_armv6_fpu.sisx - для телефонов с floating point (Nokia N95)
quake_v101_armv6_nofpu.sisx - для телефонов без fpu (Nokia 6290)
pips_s60_wp.sis - необходимая библиотека для работы игры Symbian P.I.P.S. C-Runtime library.
Ссылки:
Страница автора
Список телефонов of S60 3rd edition FP1
Видео с youtube

via: my-symbian.com , nokia-news.ru

5 comments:

Anonymous said...

Здоров,
ну а тіпа на n91вона паше?

mail to: softhacker@i.ua

Andrew said...

К сожалению нет. На днях выложу другой порт Кваки, он должен будет пойти.

Andrew said...

Quake 1 для Nokia Series 60 1st и 2nd editons
http://symbianphone.blogspot.com/2007/09/quake-1-nokia-series-60-1st-2nd-editons.html
Тестировал на Nokia N72 все в порядке, а на Nokia 6681 при запуске выскакивало сообщение - "не достаточно памяти для работы программы"

minimal said...

Спасибо за инструкцию!
Поставил себе на 6120с, вспоминаю былые времена >:D

Andrew said...

посмотри еще Duke Nukem 3d и Doom.